7 сообщений / 0 новое
Последнее сообщение
pluto
Аватар пользователя pluto
Не в сети
Последнее посещение: 2 года 3 месяца назад
Регистрация: 04/10/2012 - 21:56
Некорректный запуск Skype, помогите разобраться с профилем

Помогите с настройкой сабжа. Никак не пойму почему при запуске программы кликом из папки, интерфейс и менюшки кириллические, согласно настройкам, что в общем не критично, главное другое: тогда активны настройки - звуковые, например, выбор оборудования итп.

Но при запуске кнопкой, вручную созданной в главменю, или из консоли, и-фейс соответствует скрину 2, и настройки ты уже фиг куда подёргаешь, ибо всё серое. Хотя, на первый взгляд, всё работает - за исключением звуковых оповещений, но второй в-т не устраивает, решил заморочиться с корректным вариантом, чтобы и получше систему узнать, - где-что лежать должно, как пути не напутать, итд., да и вообще, так правильно, по-идее. Тем более, что в первом случае работает всё и так.

Я догадываюсь конечно, что во втором случае skype просто запускается дефолтно, т.к. не видит профиля или конфига, какой-нибудь xml-ки, или пути, хотя кнопку я создал стандартно - как например для почтовика Thunderbird, который все настройки прекрасно сохраняет, RAdmin'a или Firefox, - его профиль я знаю как корёжить.


SuSE: 11.1; Skype static-2.0.0.72
Папки: в корневой пользователя папка skype (папки иконок, звуков, языков, там и файл запуска) и .Skype, созданной при первом запуске самой программой, содержит папку профиля пользователя + настроечный shared.xml и какой-то shared.lck с нулём байт.

Перенос профиля и конфигов ничего не дал. Как и удаление и создание по-новой Посмотрите свои настройки pls, куда там что пишется, а то всякий раз лазить и запускать из папки некошерно.

UPDATE: всё пофикшено, нашёл одноимённую rpm-ку, переустановил прям "поверх", что, конечно, безобразие, ничего не пересоздавая ни в каких меню. Теперь всё запускается нормально, настройки целы. Адрес архивных скайпов на всякий случай засейвил. Изменения в конфигах поищу потом, а тему можно закрывать.

Теги: 

Отредактировано: lecksys вкл 04/04/2014 - 10:19
slawdos
Аватар пользователя slawdos
Не в сети
Последнее посещение: 7 месяцев 3 недели назад
Регистрация: 13/05/2012 - 15:43
ярлык из папки на рабочий

ярлык из папки на рабочий стол. обновить систему хотябы до 11.4

oS Leap 42.1x64KDE
~ Morpheus, i know linux...

tuoma
Аватар пользователя tuoma
Не в сети
Последнее посещение: 5 лет 2 недели назад
Регистрация: 23/05/2012 - 11:53
права

В консоли запускаете с правами текущего пользователя или su?
И непонятно, зачем в меню создавать какие-то кнопки. Rpm скайпа это делает сам.

ovli
Аватар пользователя ovli
Не в сети
Последнее посещение: 2 года 8 месяцев назад
Регистрация: 24/10/2012 - 19:29
А у меня тоже проблема со скайп

Звук и микрофон есть, видео нет ...даже проверку видео не предлагает...Подумал что может нет драйвера на камеру...На сайте производителя (Lenovo b570) драйвера под линукс не предлагаются, только под винду

исправилось само по себе...развернул в полноэкранный, выключил и включил значек камеры...все нормально

ovli
Аватар пользователя ovli
Не в сети
Последнее посещение: 2 года 8 месяцев назад
Регистрация: 24/10/2012 - 19:29
а теперь и уменя проблема

Короче переставил систему, скачал скайп и установил...нет звука и даже тестовый вызов не запускается, так и пишет проблемы со звуком...При запуске из командной строки запускается скайп и в командной строке выдает
что не может открыть какие-то библиотеки, целая портянка...
name@linux-vqr6:~> skype
ALSA lib dlmisc.c:236: (snd1_dlobj_cache_get) Cannot open shared library /usr/lib/alsa-lib/libasound_module_pcm_pulse.so
...........
........
ALSA lib dlmisc.c:236: (snd1_dlobj_cache_get) Cannot open shared library /usr/lib/alsa-lib/libasound_module_ctl_pulse.so
ALSA lib dlmisc.c:236: (snd1_dlobj_cache_get) Cannot open shared library /usr/lib/alsa-lib/libasound_module_pcm_pulse.so
...........

DA
Аватар пользователя DA
Не в сети
Последнее посещение: 1 год 5 месяцев назад
Регистрация: 11/05/2012 - 18:24
Пульсаудио установлено?

Пульсаудио установлено?

openSUSE 13.1 x64 | Linux 3.11 | KDE 4.13
openSUSE 12.3 x32 | Linux 3.7 | KDE 4.10
ovli
Аватар пользователя ovli
Не в сети
Последнее посещение: 2 года 8 месяцев назад
Регистрация: 24/10/2012 - 19:29
PulsАudio

Спасибо решено....http://ru.opensuse.org/PulseAudio
Для того, чтобы все приложения, поддерживающие ALSA, но не поддерживающие pelseaudio, воспроизводили звук через pulseaudio, необходимо установить alsa-plugins-pulse (в том числе 32bit пакет, если используется 64bit платформа) и прописать следующую переменную:
.....
Я просто alsa-plugins-pulse ввел в поисковик установки программ и доустановил всё что предложили...скайп заработал корректно