7 сообщений / 0 новое
Последнее сообщение
kostya0104
Аватар пользователя kostya0104
Не в сети
Последнее посещение: 3 года 2 месяца назад
Регистрация: 16/09/2014 - 15:39
Проблема с доступом к общей папке из под Win 7

Скажу, что я не профи.
Нужна простая сеть через роутер.
Клиент - Windows 7 (не домен, а рабочая группа WORKGROUP)
Файл-сервер - OpenSUSE 13.1 (графическая оболочка KDE)
К файл-серверу подключен USB винт (питание от розетки, один NTFS раздел) - для торрента.
Настроил самбу, пробно добавил (расшарил) папки с файл-сервера (на рабочем столе) и обрадовался, когда на клиенте через сеть (\\192.168.1.35\Test) я увидел заветные файлы и папки - при прошлых настройках самбы были различные проблемы, то доступа не было, то какой то пароль предлагалось вводить.
Сейчас же возникла проблема, все расшаренные папки видит, заходит, которые на файловой системе Ext4 (на диске, куда установлен файловый-сервер). Если же через самбу или через свойства папки настроить доступ к папке на USB винчестере с одним разделом, выходит запрос паролей каких то...


...иногда выходит ошибка подключения к папке или например в TotalCommander выводит "Нет доступа или файл \\192.168.1.35\Test уже используется, или в проводнике чуть другая ошибка...

...открываю "дельфина" захожу в usb-диск, иногда сразу открывает содержимое, а иногда выводит такую ошибку:


При обращении к «Домашняя папка» произошла ошибка, ответ системы: The device is already mounted: Device /dev/sdb1 is already mounted at `/var/run/media/kostya/Torrent_Share', `/run/media/kostya/Torrent_Share'.

А Убунте все хорошо работало, но правда на ней все очень медленно работало, а тут заметно быстрее.
Если кратко: На OpenSUSE установлен торрент, он сохраняет файлы на usb-диск и чтобы с Windows компьютера по сети я мог видеть эти файлы (не обязательно с возможностью записи)

Теги: 

Отредактировано: iwtke вкл 16/09/2014 - 16:51
iwtke
Аватар пользователя iwtke
Не в сети
Последнее посещение: 1 год 10 месяцев назад
Регистрация: 11/04/2014 - 19:09
посмотри:

посмотри:


yast > брандмауэр > разрешенные службы

если сидишь за роутером, то брандмауэр, в принципе, можно отключить.

Русскоязычное сообщество openSUSE
Правильно заданный вопрос – половина ответа.

kostya0104
Аватар пользователя kostya0104
Не в сети
Последнее посещение: 3 года 2 месяца назад
Регистрация: 16/09/2014 - 15:39
я его отключал

При включенном брандмауэре и добавленных портах и при отключенном проблема сохраняется.
Я же говорю на Ext4 он видит папки, а на NTFS (по USB подключен) не видит. Причем тут брандмауэр?

iwtke
Аватар пользователя iwtke
Не в сети
Последнее посещение: 1 год 10 месяцев назад
Регистрация: 11/04/2014 - 19:09
речь же о сетке, при том и

речь же о сетке, при том и брандмауэр.
ты не пробовал просто через Dolphin нужный каталог расшарить? там это в две тычки делается.

Русскоязычное сообщество openSUSE
Правильно заданный вопрос – половина ответа.

kostya0104
Аватар пользователя kostya0104
Не в сети
Последнее посещение: 3 года 2 месяца назад
Регистрация: 16/09/2014 - 15:39
А как же?

А как же?

kostya0104
Аватар пользователя kostya0104
Не в сети
Последнее посещение: 3 года 2 месяца назад
Регистрация: 16/09/2014 - 15:39
Проблема решилась, но

Проблема решилась, но возникли другие проблемы.
-Удалил NTFS;
-Отформатировал в ext4;
-При форматировании задал точку /home/torrent
-Под root сделал расшарил папку
-Сделал автологин root
Все заработало.
Поковырялся в настройках системы...везде нажимал "Отмена", чтобы изменения не внеслись - пропал интернет, при это локальная сеть есть.

Maestro☭
Аватар пользователя Maestro☭
Не в сети
Последнее посещение: 1 месяц 3 недели назад
Регистрация: 25/02/2014 - 18:00
автологин root это сильно.

автологин root это сильно.