17 сообщений / 0 новое
Последнее сообщение
fedorfed
Аватар пользователя fedorfed
Не в сети
Последнее посещение: 2 года 5 месяцев назад
Регистрация: 20/03/2015 - 17:44
Как обновить библиотеки libgcc_s1 и libstdc++6

Доброго дня!
Пытаюсь обновить библиотеки libgcc_s1 и libstdc++6
ОC Suse Server SP3 for SAP. Нужны новые библиотеки для установки SAP HANA
При обновлении возникает конфликт зависимостей и если удаляю их сносит весь сервер
Обновляю через Yast и zypper все равно конфликт зависимостей

Версия libgcc_s1 = libgcc_s1 4.7.2_20130108-0.15.45, а нужна версия 4.7.2_201301108-0.17.

Как правильно обновить данные системные библиотеки?
, т.к если возникают ошибки, то сервер после обновления из-за зависимостей программ не работает!
Напишите может команды для правильного обновления
И кто знает заведомо полные репозитории SUSE SERVER
При команде
zypper up не находит часть пакетов, после ignore сносит весь сервак

Спасибо, всем за ответы заранее!!

Статус: 

Отредактировано: iwtke вкл 24/03/2015 - 18:14
fedorfed
Аватар пользователя fedorfed
Не в сети
Последнее посещение: 2 года 5 месяцев назад
Регистрация: 20/03/2015 - 17:44
suse server 11 SP3

suse server 11 SP3

slawdos
Аватар пользователя slawdos
Не в сети
Последнее посещение: 7 месяцев 2 недели назад
Регистрация: 13/05/2012 - 15:43
наверное подойдут репозитории

наверное подойдут репозитории opensuse раз вы без подписки. https://ru.opensuse.org/%D0%A0%D0%B5%D0%BF%D0%BE%D0%B7%D0%B8%D1%82%D0%BE...

oS Leap 42.1x64KDE
~ Morpheus, i know linux...

fedorfed
Аватар пользователя fedorfed
Не в сети
Последнее посещение: 2 года 5 месяцев назад
Регистрация: 20/03/2015 - 17:44
Как раз этими репозиториями и

Как раз этими репозиториями и пользуюсь!
Но при обновлении возникает конфликт со старой версией, и обновить не могу.
Если удаляю, то сносит весь сервер.
Кроме того в этих репозиториях не все есть пакеты
Может знаете инструкцию как правильно обновить руками?

slawdos
Аватар пользователя slawdos
Не в сети
Последнее посещение: 7 месяцев 2 недели назад
Регистрация: 13/05/2012 - 15:43
Значит на этой библиотеке

Значит на этой библиотеке работает еще что-то важное. удаляйте, смотрите логи.
Руками? Врядли получится, раз автоматом не выходит. Но есть 2 возможности. найти rpm-пакет (опять же зависимости может не подтянуть) и собрать из сырцов.
Вообще мне непонятно, зачем ставить SLES если нет возможности платить за поддержку.

oS Leap 42.1x64KDE
~ Morpheus, i know linux...

fedorfed
Аватар пользователя fedorfed
Не в сети
Последнее посещение: 2 года 5 месяцев назад
Регистрация: 20/03/2015 - 17:44
Нахожу rpm пакет, ставлю

Нахожу rpm пакет, ставлю руками, вылетает зависимость с предыдущей версией.
Да важная библиотека компилятора C++. На ней куча приложений завязано!
Ставлю SLES потому что Дистрибутивы SAP заточены только под SLES. Так бы Centos поставил бы и не парился, там такого геморрой нет.
Все через yum install или yum update прекрасно выходит!

А подскажите, как собирать из сырцов, есть инструкция? И в чем плюс?

slawdos
Аватар пользователя slawdos
Не в сети
Последнее посещение: 7 месяцев 2 недели назад
Регистрация: 13/05/2012 - 15:43
Да собирать наверное толку

Да собирать наверное толку небудет, раз так невзлетает. А переустановить не вариант? и пока шареваре обновиться? там вроде 2 месяца триал...

oS Leap 42.1x64KDE
~ Morpheus, i know linux...

fedorfed
Аватар пользователя fedorfed
Не в сети
Последнее посещение: 2 года 5 месяцев назад
Регистрация: 20/03/2015 - 17:44
Так я в Yast захожу и ставлю

Так я в Yast захожу и ставлю на update, а он сразу выдает сообщение о ошибке конфликта зависимостей! Может можно как-то одну версию заблокировать, а новую поставить!?

slawdos
Аватар пользователя slawdos
Не в сети
Последнее посещение: 7 месяцев 2 недели назад
Регистрация: 13/05/2012 - 15:43
Все таки гугель рулит - https

Все таки гугель рулит - https://www.suse.com/support/update/announcement/2015/suse-ru-20150276-1...

This update for gcc47 removes libgcc1 provides and conflicts to allow the
transition to gcc48 runtime packages in future Service Packs.

oS Leap 42.1x64KDE
~ Morpheus, i know linux...

fedorfed
Аватар пользователя fedorfed
Не в сети
Последнее посещение: 2 года 5 месяцев назад
Регистрация: 20/03/2015 - 17:44
Спасибо, попробую! Главное

Спасибо, попробую! Главное чтобы он все зависимости подтянул приложения.
Я то обновлял все пакеты, но потом он что-то не находит или возникает конфликт. Сервак падает.
Я с SUSE не работаю, почему такой геммор тут с зависимостями?

iwtke
Аватар пользователя iwtke
Не в сети
Последнее посещение: 1 год 10 месяцев назад
Регистрация: 11/04/2014 - 19:09
потому что релиз старый, хоть

потому что релиз старый, хоть и поддерживаемый. такой гемор будет с любым устаревшим дистрибутивом.
рассылают максимум обновления безопасности, но не новые версии пакетов.

Русскоязычное сообщество openSUSE
Правильно заданный вопрос – половина ответа.

slawdos
Аватар пользователя slawdos
Не в сети
Последнее посещение: 7 месяцев 2 недели назад
Регистрация: 13/05/2012 - 15:43
SLES 11 старый? другой вроде

SLES 11 старый? другой вроде нераздают...

oS Leap 42.1x64KDE
~ Morpheus, i know linux...

iwtke
Аватар пользователя iwtke
Не в сети
Последнее посещение: 1 год 10 месяцев назад
Регистрация: 11/04/2014 - 19:09
История версий

Русскоязычное сообщество openSUSE
Правильно заданный вопрос – половина ответа.

fedorfed
Аватар пользователя fedorfed
Не в сети
Последнее посещение: 2 года 5 месяцев назад
Регистрация: 20/03/2015 - 17:44
Сейчас уже новый SLES 12 на

Сейчас уже новый SLES 12 на нем все завелось. Но серверные компоненты SAP B1 (ERP система такая крутая) поддерживается только на ОС SLES 11 SP2 или SP3. Так что скачал на ихнем сайте другой дистриб SAP и буду пробовать его, может не потребует этих библиотек. Ну а потребует, буду накатывать обновления. Вообще засада с системными библиотеками, какая-нибудь софтина их захочет и что ОС переустанавливать, а если у тебя сервак с ERP системой или критичными сервисами, то пипец вообще!

fedorfed
Аватар пользователя fedorfed
Не в сети
Последнее посещение: 2 года 5 месяцев назад
Регистрация: 20/03/2015 - 17:44
Вопрос! А в каком репозитории

Вопрос! А в каком репозитории есть это обновление исправлений?
Добавил репозитории 11 и 12 версий, смотрю некоторые уже устарели(

fedorfed
Аватар пользователя fedorfed
Не в сети
Последнее посещение: 2 года 5 месяцев назад
Регистрация: 20/03/2015 - 17:44
Не могу найти Java 1_6 или 1

Не могу найти Java 1_6 или 1_7 в репозиториях! У меня стоит 1_5

fedorfed
Аватар пользователя fedorfed
Не в сети
Последнее посещение: 2 года 5 месяцев назад
Регистрация: 20/03/2015 - 17:44
Нашел другой дистриб, JAVA

Нашел другой дистриб, JAVA поставил. Тему можно закрыть думаю! Спасибо всем большое за ответы

Тема заблокирована