6 сообщений / 0 новое
Последнее сообщение
dima81
Аватар пользователя dima81
Не в сети
Последнее посещение: 1 неделя 57 минут назад
Регистрация: 25/10/2017 - 22:17
Настройка сенсоров на ноуте

При вызове sensors, получаю такоей вывод:
coretemp-isa-0000
Adapter: ISA adapter
Package id 0: +56.0°C (high = +72.0°C, crit = +90.0°C)
Core 0: +55.0°C (high = +72.0°C, crit = +90.0°C)
Core 1: +53.0°C (high = +72.0°C, crit = +90.0°C)

acpitz-virtual-0
Adapter: Virtual device
temp1: +56.0°C (crit = +88.0°C)
temp2: +43.0°C (crit = +126.0°C)

thinkpad-isa-0000
Adapter: ISA adapter
fan1: 0 RPM

Возник вопрос почему не кажет напряжения, скорость вращения вентилятора, а сам вентилятор работаете как сумасшедший, изредка только выключается. Думаю дело в каких то драйверах, но счего начать их установку ума не приложу. Может знающие люди подскажут?

-------------
Вывод lspci
00:00.0 Host bridge: Intel Corporation 3rd Gen Core processor DRAM Controller (rev 09)
00:01.0 PCI bridge: Intel Corporation Xeon E3-1200 v2/3rd Gen Core processor PCI Express Root Port (rev 09)
00:02.0 VGA compatible controller: Intel Corporation 3rd Gen Core processor Graphics Controller (rev 09)
00:14.0 USB controller: Intel Corporation 7 Series/C210 Series Chipset Family USB xHCI Host Controller (rev 04)
00:16.0 Communication controller: Intel Corporation 7 Series/C216 Chipset Family MEI Controller #1 (rev 04)
00:1a.0 USB controller: Intel Corporation 7 Series/C216 Chipset Family USB Enhanced Host Controller #2 (rev 04)
00:1b.0 Audio device: Intel Corporation 7 Series/C216 Chipset Family High Definition Audio Controller (rev 04)
00:1c.0 PCI bridge: Intel Corporation 7 Series/C216 Chipset Family PCI Express Root Port 1 (rev c4)
00:1c.1 PCI bridge: Intel Corporation 7 Series/C210 Series Chipset Family PCI Express Root Port 2 (rev c4)
00:1c.3 PCI bridge: Intel Corporation 7 Series/C216 Chipset Family PCI Express Root Port 4 (rev c4)
00:1d.0 USB controller: Intel Corporation 7 Series/C216 Chipset Family USB Enhanced Host Controller #1 (rev 04)
00:1f.0 ISA bridge: Intel Corporation HM77 Express Chipset LPC Controller (rev 04)
00:1f.2 SATA controller: Intel Corporation 7 Series Chipset Family 6-port SATA Controller [AHCI mode] (rev 04)
00:1f.3 SMBus: Intel Corporation 7 Series/C216 Chipset Family SMBus Controller (rev 04)
01:00.0 3D controller: NVIDIA Corporation GF117M [GeForce 610M/710M/810M/820M / GT 620M/625M/630M/720M] (rev a1)
03:00.0 Network controller: Broadcom Limited BCM43142 802.11b/g/n (rev 01)
04:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller (rev 07)

Комп ноут lenovo B590, проц core i3, карта вроде GMA950 и NVIDIA какая то. Так то всё работает, только BT не проверял. Но из коробки в бубунте не заработало, приходилось настраивать.

Отредактировано: dima81 вкл 26/10/2017 - 23:14
Nicom
Аватар пользователя Nicom
Не в сети
Последнее посещение: 18 часов 23 минуты назад
Регистрация: 11/02/2014 - 11:22
dima81 wrote:
dima81 wrote:

скорость вращения вентилятора, а сам вентилятор работаете как сумасшедший, изредка только выключается.

Для начала поставить powertop и htop, посмотреть на загрузку процессора в htop, и на каких частотах в основном работает процессор в powertop.
То что вентилятор работает постоянно и температура при этом около 50 градусов может говорить о забитом пылью радиаторе или о плохом отводе тепла с кристалла процессора, посмотреть как теплотрубка прилегает к процессору и в каком состоянии термопаста, естественно для этого придётся разобрать весь ноутбук.
Но может оказаться что какое то приложение просто активно использует процессор.

По поводу напряжений. sensors-detect делали?

dima81
Аватар пользователя dima81
Не в сети
Последнее посещение: 1 неделя 57 минут назад
Регистрация: 25/10/2017 - 22:17
sensors-detect делал

sensors-detect делал

# sensors-detect revision 6284 (2015-05-31 14:00:33 +0200)
# System: LENOVO 20208 [Lenovo B590] (laptop)
# Kernel: 4.13.10-1-default x86_64
# Processor: Intel(R) Core(TM) i3-3110M CPU @ 2.40GHz (6/58/9)

This program will help you determine which kernel modules you need
to load to use lm_sensors most effectively. It is generally safe
and recommended to accept the default answers to all questions,
unless you know what you're doing.

Some south bridges, CPUs or memory controllers contain embedded sensors.
Do you want to scan for them? This is totally safe. (YES/no): y
Module cpuid loaded successfully.
Silicon Integrated Systems SIS5595... No
VIA VT82C686 Integrated Sensors... No
VIA VT8231 Integrated Sensors... No
AMD K8 thermal sensors... No
AMD Family 10h thermal sensors... No
AMD Family 11h thermal sensors... No
AMD Family 12h and 14h thermal sensors... No
AMD Family 15h thermal sensors... No
AMD Family 16h thermal sensors... No
AMD Family 15h power sensors... No
AMD Family 16h power sensors... No
Intel digital thermal sensor... Success!
(driver `coretemp')
Intel AMB FB-DIMM thermal sensor... No
Intel 5500/5520/X58 thermal sensor... No
VIA C7 thermal sensor... No
VIA Nano thermal sensor... No

Some Super I/O chips contain embedded sensors. We have to write to
standard I/O ports to probe them. This is usually safe.
Do you want to scan for Super I/O sensors? (YES/no): y
Probing for Super-I/O at 0x2e/0x2f
Trying family `National Semiconductor/ITE'... No
Trying family `SMSC'... No
Trying family `VIA/Winbond/Nuvoton/Fintek'... No
Trying family `ITE'... No
Probing for Super-I/O at 0x4e/0x4f
Trying family `National Semiconductor/ITE'... Yes
Found unknown chip with ID 0xfc11

Some hardware monitoring chips are accessible through the ISA I/O ports.
We have to write to arbitrary I/O ports to probe them. This is usually
safe though. Yes, you do have ISA I/O ports even if you do not have any
ISA slots! Do you want to scan the ISA I/O ports? (YES/no): y
Probing for `National Semiconductor LM78' at 0x290... No
Probing for `National Semiconductor LM79' at 0x290... No
Probing for `Winbond W83781D' at 0x290... No
Probing for `Winbond W83782D' at 0x290... No

Lastly, we can probe the I2C/SMBus adapters for connected hardware
monitoring devices. This is the most risky part, and while it works
reasonably well on most systems, it has been reported to cause trouble
on some systems.
Do you want to probe the I2C/SMBus adapters now? (YES/no): y
Using driver `i2c-i801' for device 0000:00:1f.3: Intel Panther Point (PCH)
Module i2c-dev loaded successfully.

Next adapter: SMBus I801 adapter at efa0 (i2c-0)
Do you want to scan it? (YES/no/selectively): y
Client found at address 0x52
Probing for `Analog Devices ADM1033'... No
Probing for `Analog Devices ADM1034'... No
Probing for `SPD EEPROM'... Yes
(confidence 8, not a hardware monitoring chip)

Next adapter: i915 gmbus ssc (i2c-1)
Do you want to scan it? (yes/NO/selectively): y

Next adapter: i915 gmbus vga (i2c-2)
Do you want to scan it? (yes/NO/selectively): y

Next adapter: i915 gmbus panel (i2c-3)
Do you want to scan it? (yes/NO/selectively): y

Next adapter: i915 gmbus dpc (i2c-4)
Do you want to scan it? (yes/NO/selectively): y
y
Next adapter: i915 gmbus dpb (i2c-5)
Do you want to scan it? (yes/NO/selectively):y

Next adapter: i915 gmbus dpd (i2c-6)
Do you want to scan it? (yes/NO/selectively): y

Next adapter: DPDDC-B (i2c-7)
Do you want to scan it? (yes/NO/selectively): n

Next adapter: NVIDIA i2c adapter 3 at 1:00.0 (i2c-8)
Do you want to scan it? (yes/NO/selectively): y
Adapter cannot be probed, skipping.

Now follows a summary of the probes I have just done.
Just press ENTER to continue:

Driver `coretemp':
* Chip `Intel digital thermal sensor' (confidence: 9)

Do you want to overwrite /etc/sysconfig/lm_sensors? (YES/no): y
Unloading i2c-dev... OK
Unloading cpuid... OK

Вывод sensors

coretemp-isa-0000
Adapter: ISA adapter
Package id 0: +57.0°C (high = +72.0°C, crit = +90.0°C)
Core 0: +53.0°C (high = +72.0°C, crit = +90.0°C)
Core 1: +56.0°C (high = +72.0°C, crit = +90.0°C)

acpitz-virtual-0
Adapter: Virtual device
temp1: +57.0°C (crit = +88.0°C)
temp2: +42.0°C (crit = +126.0°C)

thinkpad-isa-0000
Adapter: ISA adapter
fan1: 0 RPM

Вывод powertop

Package | Core | CPU 0 CPU 1
| | Actual 1349 MHz 1380 MHz
Idle 92,2% | Idle 95,8% | Idle 97,6% 97,8%
2,40 GHz 0,6% | 2,40 GHz 0,4% | 1300 MHz 0,1% 0,3%
1300 MHz 0,3% | 1300 MHz 0,2% | 2,40 GHz 0,2% 0,0%
1400 MHz 0,3% | 1400 MHz 0,2% | 1400 MHz 0,1% 0,1%
1500 MHz 0,1% | 1500 MHz 0,0% | 1500 MHz 0,0% 1,5%
1200 MHz 5,9% | 1,60 GHz 0,1% | 1,60 GHz 0,0% 0,1%
1,60 GHz 0,1% | 1200 MHz 3,0% | 1200 MHz 1,7% 0,0%
1,71 GHz 0,4% | 1,71 GHz 0,2% | 1,71 GHz 0,2% 0,1%
2,00 GHz 0,0% | 2,00 GHz 0,0% | 2,00 GHz 0,0% 0,0%
1,91 GHz 0,0% | 1,91 GHz 0,0% | 1,91 GHz 0,0% 0,0%
1,80 GHz 0,0% | 1,80 GHz 0,0% | 1,80 GHz 0,0% 0,0%

| Core | CPU 2 CPU 3
| | Actual 1323 MHz 1315 MHz
| Idle 95,6% | Idle 96,7% 98,6%
| 2,40 GHz 0,3% | 1300 MHz 0,1% 0,0%
| 1300 MHz 0,2% | 2,40 GHz 0,2% 0,1%
| 1400 MHz 0,1% | 1400 MHz 0,1% 0,0%
| 1500 MHz 0,1% | 1500 MHz 0,1% 0,1%
| 1200 MHz 3,4% | 1200 MHz 2,7% 1,0%
| 1,71 GHz 0,2% | 1,71 GHz 0,1% 0,1%
| 1,60 GHz 0,0% | 1,60 GHz 0,0% 0,0%
| 2,00 GHz 0,0% | 2,00 GHz 0,0% 0,0%
| 1,91 GHz 0,0% | 1,91 GHz 0,0% 0,0%

Чистку ещё не делал, на днях собираюсь вскрыть и посмотреть что там.

opensuse tumbleweed

Nicom
Аватар пользователя Nicom
Не в сети
Последнее посещение: 18 часов 23 минуты назад
Регистрация: 11/02/2014 - 11:22
dima81 wrote:
dima81 wrote:

sensors-detect делал

Intel digital thermal sensor... Success!
Trying family `National Semiconductor/ITE'... Yes
Found unknown chip with ID 0xfc11

Вывод sensors

acpitz-virtual-0
Adapter: Virtual device
temp1: +57.0°C (crit = +88.0°C)
temp2: +42.0°C (crit = +126.0°C)

thinkpad-isa-0000
Adapter: ISA adapter
fan1: 0 RPM

Вывод powertop

Package | Core | CPU 0 CPU 1
| | Actual 1349 MHz 1380 MHz
Idle 92,2% | Idle 95,8% | Idle 97,6% 97,8%

| Core | CPU 2 CPU 3
| | Actual 1323 MHz 1315 MHz
| Idle 95,6% | Idle 96,7% 98,6%

Судя по тому, что процессор совсем не нагружен, работает почти на самой низкой частоте и простаивает более 95% времени, а температура у него при этом более 50 градусов, то напрашивается вывод о плохом теплоотводе. С другой стороны сторка fan1: 0 RPM, может говорить о двух вещах,
первое: - lmsensors просто не знает как работать с найденой микросхемой Found unknown chip with ID 0xfc11 и соответственно подставляет нулевое значение,
второе: - с контрольного провода вентилятора не поступают сигналы и BIOS, основываясь на нулевых показателях и высокой температуре CPU, сознательно занижает частоту процессора. Но здесь опять же, для начала, нужно смотреть чистоту радиатора и термоинтерфейс процессора, ну не должно быть такой высокой температуры при постоянно работающем вентиляторе! Если радиатор системы охлаждения чистый, и термоинтерфейс в порядке, но тепло отводится плохо, то есть вероятность повреждения теплотрубки.

dima81
Аватар пользователя dima81
Не в сети
Последнее посещение: 1 неделя 57 минут назад
Регистрация: 25/10/2017 - 22:17
Буду вскрывать, чистить.

Буду вскрывать, чистить. Потом отпишусь.

opensuse tumbleweed

dima81
Аватар пользователя dima81
Не в сети
Последнее посещение: 1 неделя 57 минут назад
Регистрация: 25/10/2017 - 22:17
Почистил из заменил

Почистил из заменил термопасту. Пыли немного было, тармопаста еще жидинькая, не закоксованная. Сейчас кажет 50 С. Вентилятор при 58 примерно включается.

opensuse tumbleweed