8 сообщений / 0 новое
Последнее сообщение
seosova
Аватар пользователя seosova
Не в сети
Последнее посещение: 4 года 3 недели назад
Регистрация: 14/11/2013 - 18:24
Настройка Apache

Здравствуйте. Первый раз тут - надеюсь не ошибся веткой форума.
Имеется, странная ошибка apache на openSUSE 12.3. Скорее всего ошибка в самой настройке апача, прошу помочь с поисками)
Ситуация такая:
Поставил openSUSE 12.3(KDE). Отдельно поставил apache,MySQL,php,phpMYAdmin. Настроил через Yast. Добавил host в домашнюю папку в public_html. Чтобы работали адреса вида site1,site2 - добавил имена узла. Все работает. Скачал копию сайта на joomla, поставил. Работает админка и главная страница сайта, но неработают ссылке на сайте - выдает вечно 404. То есть в админке нормально функцианируют переходы, а на сайте ни одна ссылки никуда не ведет. Проверил на нескольких сайтах.
В чем может быть проблема?
Так же не могу никак решить недочет с правами. Как дать возможность апачу запускаться с парвами записи в мой public_html? Добавил папку в группу www - не помогает(

P.S. права доступа на 404 ошибку никак не вляют, ибо ставил везде тупо 777 для теста - ничего не меняется(

Может кто сталкивался с таким?

Теги: 

Отредактировано: lecksys вкл 01/04/2014 - 22:14
gluka
Аватар пользователя gluka
Не в сети
Последнее посещение: 3 года 8 месяцев назад
Регистрация: 14/11/2013 - 20:58
.htaccess файл есть?

.htaccess файл есть?
без джумлы, на статике все работает?

seosova
Аватар пользователя seosova
Не в сети
Последнее посещение: 4 года 3 недели назад
Регистрация: 14/11/2013 - 18:24
Да тоже мысли что в нем дело

Да и джумла то внутри себя нормально пашет, всмысле админка. Все настраивается, все ходит. .htaccess есть, но взят полностью с сервера. Грешил на него тоже, но не смог найти в чем может быть ошибка + попробовал без перенаправления включить и удалить .htaccess - ничего не поменялось( Может реально в нем дело? Что делать тогда?

p.s. специально проверил ещё раз, даже если засунуть статическую страницу в папку с джумлой - нормально можно на нее перейти

gluka
Аватар пользователя gluka
Не в сети
Последнее посещение: 3 года 8 месяцев назад
Регистрация: 14/11/2013 - 20:58
sudo less /var/log/apache2

sudo less /var/log/apache2/error_log

че там?

seosova
Аватар пользователя seosova
Не в сети
Последнее посещение: 4 года 3 недели назад
Регистрация: 14/11/2013 - 18:24
Вывод

Заранее спасибо за помощь.

Перезагрузил apache и mysql. Вывожу конец лога, сразу после перезагрузки. Попробывал пройти по 3-м ссылкам- все выдали 404.


[Sat Nov 16 00:50:42 2013] [notice] caught SIGTERM, shutting down
[Sat Nov 16 00:50:42 2013] [notice] mod_python: Creating 8 session mutexes based on 150 max processes and 0 max threads.
[Sat Nov 16 00:50:42 2013] [notice] mod_python: using mutex_directory /tmp
[Sat Nov 16 00:50:42 2013] [notice] Apache/2.2.22 (Linux/SUSE) PHP/5.3.17 mod_python/3.3.1 Python/2.7.3 configured -- resuming normal operations
[Sat Nov 16 00:51:26 2013] [error] [client 127.0.0.1] File does not exist: /home/lightstar/public_html/test.site1/voskhozhdenie-na-elbrus, referer: http://test.site1/
[Sat Nov 16 00:51:31 2013] [error] [client 127.0.0.1] File does not exist: /home/lightstar/public_html/test.site1/all, referer: http://test.site1/
[Sat Nov 16 00:51:34 2013] [error] [client 127.0.0.1] File does not exist: /home/lightstar/public_html/test.site1/programma, referer: http://test.site1/

Это лог сайта где я уже отключил .htaccess. Другой сайт с работающим .htaccess выдал тоже самое( те же ошибки.

gluka
Аватар пользователя gluka
Не в сети
Последнее посещение: 3 года 8 месяцев назад
Регистрация: 14/11/2013 - 20:58
без .htaccess ничего и не

без .htaccess ничего и не должно работать, а вот то что с ним тоже самое - странно. он ведь не пустой, а некий дефолтный джумловский ?

mod_rewrite для апача установлен?

veb
Аватар пользователя veb
Не в сети
Последнее посещение: 11 месяцев 4 недели назад
Регистрация: 22/11/2013 - 10:47
mod_rewrite точно отключен,

mod_rewrite точно отключен, ибо сссылки у тебя выглядят как ЧПУ (человеко-понятные урлы). Варианта решения проблемы 2: включить mod_rewrite (скорее всего в .htaccess достаточно добавить RewriteEngine on в самое его начало) или в joomla отключить ЧПУ (вроде как это можно сделать http://joomlaforum.ru/index.php?topic=76867.0)

veb
Аватар пользователя veb
Не в сети
Последнее посещение: 11 месяцев 4 недели назад
Регистрация: 22/11/2013 - 10:47
он вроде как сейчас по

он вроде как сейчас по дефолту сам ставится, достаточно потом в .htaccess активировать и все