9 сообщений / 0 новое
Последнее сообщение
sv_lary
Аватар пользователя sv_lary
Не в сети
Последнее посещение: 11 месяцев 2 недели назад
Регистрация: 04/11/2014 - 17:53
Не работают программы сканирования

Не могу заставить работать сканер Epson Perfection V500. Само устройство и соединительный кабель исправны - перезагрузившись в Windows нормально сканирую.

На USB шине устройство присутствует:


# lsusb
. . .
Bus 004 Device 005: ID 04b8:0130 Seiko Epson Corp. GT-X770 [Perfection V500]
. . .

На прикладном уровне (с правами root) устройство распознаётся:


# sane-find-scanner -q
found USB scanner (vendor=0x04b8 [EPSON], product=0x0130 [EPSON Scanner]) at libusb:004:005
# scanimage -L
device `epkowa:usb:004:005' is a Epson (unknown model) flatbed scanner
device `epkowa:usb:004:005' is a Epson (unknown model) flatbed scanner

Что любопытно, scanimage выдаёт его почему-то дважды...

Но, ни одна прикладная пргорамма (xsane, iscan, scanlite...) работать не могут. При их запуске выдаётся либо, что устройство невозможно проинициализировать, либо невозможно передать команду.

Настроечные файлы выглядят так:

  • /etc/sane.d/dll.conf - выбрано epkowa, остальное всё закрыто
  • /etc/sane.d/epkova - Указано устройство usb 04b8:0130
  • /etc/sane.d/epson - Всё закрыто
  • /etc/sane.d/epson2 - Всё закрыто
  • /usr/share/ iscan-data/usb - Ручками дописал устройство 04b8:0130

Самое обидное, что в ранее установленной бубунте 12.04 сканер работал великолепно... Sad

Теги: 

iwtke
Аватар пользователя iwtke
Не в сети
Последнее посещение: 1 год 10 месяцев назад
Регистрация: 11/04/2014 - 19:09
быть может нужно добавить

быть может нужно добавить пользователя в группу


scanner

Русскоязычное сообщество openSUSE
Правильно заданный вопрос – половина ответа.

sv_lary
Аватар пользователя sv_lary
Не в сети
Последнее посещение: 11 месяцев 2 недели назад
Регистрация: 04/11/2014 - 17:53
Увы...

Увы... Sad

Вообще, группы 'scanner' изначально в системе не было. Я добавил её в список групп, а себя - в эту группу.
Но не помогло.

Сергей Ларионов

iwtke
Аватар пользователя iwtke
Не в сети
Последнее посещение: 1 год 10 месяцев назад
Регистрация: 11/04/2014 - 19:09
http://download.ebz.epson.net

http://download.ebz.epson.net/dsc/search/01/search/searchModule
и вот что там есть:

(скриншот исправил)

Русскоязычное сообщество openSUSE
Правильно заданный вопрос – половина ответа.

AleksandrArkhipov
Аватар пользователя AleksandrArkhipov
Не в сети
Последнее посещение: 3 года 1 неделя назад
Регистрация: 31/03/2014 - 19:52
Запустите программу от рута,

Запустите программу от рута, если не поможет, то vuescan. Его можно найти на трекерах. Запуск тоже от рут.

sv_lary
Аватар пользователя sv_lary
Не в сети
Последнее посещение: 11 месяцев 2 недели назад
Регистрация: 04/11/2014 - 17:53
iwtke wrote:
iwtke wrote:

и вот что там есть:

Да, я там был, разумеетсяя... Дело в том, что мой сканер (Epson Perfrction V500) напрямую SANE не поддерживается. И там было написано, что надо идти на сайт производителя и скачивать проприоретарные драйвера. Я скачал, установил. После этого система сканер увидела. До этого - вообще ничего не было.

Но прикладное по так и не заработало....

Сергей Ларионов

sv_lary
Аватар пользователя sv_lary
Не в сети
Последнее посещение: 11 месяцев 2 недели назад
Регистрация: 04/11/2014 - 17:53
AleksandrArkhipov wrote:
AleksandrArkhipov wrote:

Запустите программу от рута, если не поможет

  • xsane - You try to run XSane as ROOT? that really is DANGEROUS!
  • iscan - просто молчит
  • skanlite - Долго ищет устройство, показывает правильно, Далее : "kbuildsycoca4 running..." и завершается после долгой паузы.
  • scangui - Всё то же самое
AleksandrArkhipov wrote:

то vuescan. Его можно найти на трекерах. Запуск тоже от рут.

Запускается, но сканера не видит.


Не обнаружены сканеры, подключенные к вашему компьютеру, файлы в формате RAW также не были найдены.

Запускал и с правами root и как обычный пользователь.

Сергей Ларионов

ivanovsky.mic
Аватар пользователя ivanovsky.mic
Не в сети
Последнее посещение: 3 месяца 1 неделя назад
Регистрация: 08/06/2012 - 19:14
iwtke wrote:
iwtke wrote:

быть может нужно добавить пользователя в группу

scanner

Посмотреть /etc/udev/rules.d/55-libsane.rules - там видно, что группа lp
Epson perfection V100 PHOTO

Ивановский Михаил

ivanovsky.mic
Аватар пользователя ivanovsky.mic
Не в сети
Последнее посещение: 3 месяца 1 неделя назад
Регистрация: 08/06/2012 - 19:14
Имя: iscan

Имя: iscan
Версия: 2.30.1-1.usb0.1.ltdl7
Архитектура: x86_64

Имя: iscan-data
Версия: 1.36.0-1
Архитектура: noarch

Имя: iscan-plugin-gt-s600
Версия: 2.1.2-1
Архитектура: x86_64

На работающем ПК немного подождать после включения сканера, если сбоит - перевключить сканер и подождать. Или при включенном сканере перезагрузить ПК.

Ивановский Михаил