16 сообщений / 0 новое
Последнее сообщение
markizz
Аватар пользователя markizz
Не в сети
Последнее посещение: 4 года 2 месяца назад
Регистрация: 27/10/2012 - 10:04
Не ставится Linux

Всем привет. Несколько дней назад купил себе компьютер и столкнулся с невиданной ранее проблемой, невозможности установить Linux.
Сбока компа:
CPU - AMD A10 5700;
Mother - asrock fm2a85x extreme4;
GPU - AMD Radeon HD 6670, да и с Geforce 9800 gt тоже.

Поначалу думал, что дело в носителе (флэшке), но потом понял, что и с диска не выходит. Открывается загрузчик, выбираю установку и тишина. Монитор пишет "нет сигнала". С попыткой загрузки "живого" диска история та же. Самое паршивое то, что Windows ставится без проблем. Неужели пока нет драйверов под линь, и мне придется сидеть под маздаем?

Теги: 

Отредактировано: lecksys вкл 01/04/2014 - 22:14
lecksys
Аватар пользователя lecksys
Не в сети
Последнее посещение: 1 год 8 месяцев назад
Регистрация: 02/04/2012 - 11:54
Много букафф и мало

Много букафф и мало информации Smile другие дистрибутивы пробывали?


Профессиональный тролль. Работаю за еду.

markizz
Аватар пользователя markizz
Не в сети
Последнее посещение: 4 года 2 месяца назад
Регистрация: 27/10/2012 - 10:04
Да. Ubuntu, Mandriva, Mint.

Да. Ubuntu, Mandriva, Mint.

DA
Аватар пользователя DA
Не в сети
Последнее посещение: 1 год 6 месяцев назад
Регистрация: 11/05/2012 - 18:24
nomodeset noapic nolapic по

nomodeset noapic nolapic по-отдельности попробовать добавлять к параметрам загрузки ядра.

openSUSE 13.1 x64 | Linux 3.11 | KDE 4.13
openSUSE 12.3 x32 | Linux 3.7 | KDE 4.10
GriffonZoo
Аватар пользователя GriffonZoo
Не в сети
Последнее посещение: 4 года 6 месяцев назад
Регистрация: 16/05/2012 - 10:23
Видимо, у вас в BIOS включен

Видимо, у вас в BIOS включен контроль загрузки (UEFI) Все больше материнских плат появляется с этой пошестьб (прогиб перед мелкософтом) Многие lin-дистрибутивы пока не имеют подписанного загрузчика, способного работать с этой фигней. Отключите эту штуку, и должно заработать.

markizz
Аватар пользователя markizz
Не в сети
Последнее посещение: 4 года 2 месяца назад
Регистрация: 27/10/2012 - 10:04
Действительно. Такая штука и

Действительно. Такая штука и есть, только меню отключения я не нашел. В интернете есть ответы (вернее один ответ), но я облазил все пункты и не нашел. В выходные буду копаться.

GriffonZoo
Аватар пользователя GriffonZoo
Не в сети
Последнее посещение: 4 года 6 месяцев назад
Регистрация: 16/05/2012 - 10:23
На Асусовских мамках это

На Асусовских мамках это отключается при выборе загрузки с диска - с UEFI или без UEFI

r3d
Аватар пользователя r3d
Не в сети
Последнее посещение: 2 года 4 месяца назад
Регистрация: 04/09/2012 - 16:52
В целом это неверно. С самим

В целом это неверно. С самим UEFI проблем как таковых нет, эта система загрузки разработана достаточно давно. Проблема тут с майкрософтовской опцией Secure Boot на материнках с UEFI.

13.1 - Xfce
markizz
Аватар пользователя markizz
Не в сети
Последнее посещение: 4 года 2 месяца назад
Регистрация: 27/10/2012 - 10:04
Cecure Boot отключен.

Cecure Boot отключен.

r3d
Аватар пользователя r3d
Не в сети
Последнее посещение: 2 года 4 месяца назад
Регистрация: 04/09/2012 - 16:52
А, ну тогда всего-то.. тогда

А, ну тогда всего-то.. тогда можно загрузить ядро Linux через UEFI.
Т. е. я знаю, что UEFI способна непосредственно загружать ядро, без всяких Grub`ов. Но! стандартный установочный образ тут не подойдет, нужно шаманить. Сам я такого не делал, вероятно что-то можно найти в гугле. Только для новичков все это будет бесполезно скорее всего..

13.1 - Xfce
r3d
Аватар пользователя r3d
Не в сети
Последнее посещение: 2 года 4 месяца назад
Регистрация: 04/09/2012 - 16:52
Хмм..

Посмотрел в гугле.. ROSA с UEFI ставится, Ubuntu, Arch ставятся, на лоре и OpenSUSE устанавливают, правда там как всегда с бубном. Что-то у вас не то, может быть с ноутом.. а может быть, и не с ним Wink

13.1 - Xfce
Karlodun
Аватар пользователя Karlodun
Не в сети
Последнее посещение: 4 года 9 месяцев назад
Регистрация: 14/03/2013 - 14:14
Проблема с АПУ от АМД

Обойти это можно так:
Устанавливаем линукс в Виртуальной машине, при этом настраиваем монтировку разделов диска по имени, соответственно наделяем именами сами разделы.
Потом, все еще в виртуалке, устанавливаем подходящие дрова:
http://ru.opensuse.org/SDB:AMD_fglrx

Потом возвращаем диск обратно в комп/ноут и все должно работать. У меня только так, или вообще никак. Радеоновские дрова не работают вообще.
На сегодня могу сказать, что единственный дистрибутив, который без проблем встал на моем ноуте - дебиан. но опять же, без дров разрешение минимальное, и пользуеться не понятно какой именно графической картой.
В общем удачи! Я тоже должен переустановить на днях. Ибо у меня предыдущая версия слитела при попытке сделать ее рабочей на нескольких компах. Проблема была в процессе установки дров от АМД, они ломали МЕСА, после чего иные графические карты не работали. А попытка отремонтировать вообще ставит комп в тупик, и он в упор считает, что не видет монитор. Нагло отображая при этом всю информацию на том самом, вроде-как не существующем...

RusX
Аватар пользователя RusX
Не в сети
Последнее посещение: 4 года 9 месяцев назад
Регистрация: 28/02/2013 - 11:43
Процесс запуска

Можно подробнее описать процесс запуска с диска?

GriffonZoo
Аватар пользователя GriffonZoo
Не в сети
Последнее посещение: 4 года 6 месяцев назад
Регистрация: 16/05/2012 - 10:23
12.3

12.3 вроде как умеет работать с СекьюреБут и имеет подписанный загрузчик. Так что проблема должна рассосаться (с) Кашпировский

slawdos
Аватар пользователя slawdos
Не в сети
Последнее посещение: 8 месяцев 2 недели назад
Регистрация: 13/05/2012 - 15:43
Дак "вроде как", или ссылку

Дак "вроде как", или ссылку на источник дадите?

oS Leap 42.1x64KDE
~ Morpheus, i know linux...

DA
Аватар пользователя DA
Не в сети
Последнее посещение: 1 год 6 месяцев назад
Регистрация: 11/05/2012 - 18:24
Ссылка.
openSUSE 13.1 x64 | Linux 3.11 | KDE 4.13
openSUSE 12.3 x32 | Linux 3.7 | KDE 4.10