6 сообщений / 0 новое
Последнее сообщение
CyberDaemon
Аватар пользователя CyberDaemon
Не в сети
Последнее посещение: 2 года 2 месяца назад
Регистрация: 07/06/2012 - 15:54
oS 12.1 и LVM

Возникли следующие проблемы.
Есть логичесая группа Hone, на ней логический том home, там хомяк.
Есть 3 диска SCSI и на них 3 раздела sdb1, sdc1 sdd1.
Делаю VG: vgcreate VG01 /dev/sdb1 /dev/sdc1 /dev/sdd1
На них делаю логический том: lvcreate -LxxxxG -nlvol1 -i3 VG01
Всё создаётся без проблем.
ФС - ext4.
При загрузки компа VG01 не активируется.
После загрузки активация возможна вручную.
На другом компе веселей. Там 6 дисков, на которых собраны 3 раида 1-го уровня.
На них CG informix и в группе 698 томов по 2 G.
Файловой системы нет.
Всё проходит. При 1-ой же перегрузки систесы сыплет на дисплей сообщения про таймауты при работе udev. И система виснет, далее загрузка не идёт.
Помогите разобраться, в чём трабла.

Теги: 

Отредактировано: lecksys вкл 01/04/2014 - 22:11
rioky
Аватар пользователя rioky
Не в сети
Последнее посещение: 2 года 3 месяца назад
Регистрация: 11/05/2012 - 13:09
По поводу lvm - надо включить

По поводу lvm - надо включить службу boot.lvm (и если надо boot.lvm_monitor), если lvm создан после установки, их надо включать руками (яст - системные службы - экспертный режим). Про informix сказать нечего, не сталкивался


openSUSE 13.1 x86_64 / Xfce 4.10
Windows 8.1 Pro x64

CyberDaemon
Аватар пользователя CyberDaemon
Не в сети
Последнее посещение: 2 года 2 месяца назад
Регистрация: 07/06/2012 - 15:54
chkconfig boot.lvm

chkconfig boot.lvm
boot.lvm on
Включено.
boot.lvm_monitor отсутствует.
До informix-а дело не доходит, система не грузится.
Я сделал костыль - запретил инициализацию VG informix во время старта, а при стрте informix-а инициализирую.
Но хотелось бы разобраться, почему всё это ведёт себя неправильно.

rioky
Аватар пользователя rioky
Не в сети
Последнее посещение: 2 года 3 месяца назад
Регистрация: 11/05/2012 - 13:09
странно что отсутствует.

странно что отсутствует.
#rpm -qf /etc/init.d/boot.lvm_monitor
lvm2-2.02.84-19.5.1.x86_64
# rpm -qf /etc/init.d/boot.lvm
lvm2-2.02.84-19.5.1.x86_64

остаётся косяк systemd, может быть рассмотрение лога загрузки что подскажет.


openSUSE 13.1 x86_64 / Xfce 4.10
Windows 8.1 Pro x64

CyberDaemon
Аватар пользователя CyberDaemon
Не в сети
Последнее посещение: 2 года 2 месяца назад
Регистрация: 07/06/2012 - 15:54
Хм, на домашнем компьютере

Хм, на домашнем компьютере есть. Версия совпадает, толко x86.
Я склоняюсь к траблу в systemd и udf(возможно). Мне не одалось точно установить причину.
Смнена systemd на рабочем копьютере на более новую версию помагла, так же как и возврат к sysnemv. Но на сервере, где 6 дисков и куча lvil-ов, смне systemd не помогла, а возврат на sysv только усугубило ситуацию. Хорошо бы, если бы разаработчики, пока не вашла 12.2, проверили всё.

CyberDaemon
Аватар пользователя CyberDaemon
Не в сети
Последнее посещение: 2 года 2 месяца назад
Регистрация: 07/06/2012 - 15:54
Дело оказывается не в

Дело оказывается не в конкретной версии дистрибутива. Пробдема в самй ущербности LVM под Linux.
Ну не может он работать с таким количеством логическиз томов. Поэтому и глючит.
Нашел, что надо сделать pvcreate --metadatasize xxx. По умолчанию 255 секторов мало оказывается. Но вот дошел до metadatasize 10M, но 931 том создать не может. 905 максимум создаёт, потом сыпет ошибки. Может кто подскажет какие параметры надо выставитьь?