4 сообщения / 0 новое
Последнее сообщение
jsullen
Аватар пользователя jsullen
Не в сети
Последнее посещение: 3 года 11 месяцев назад
Регистрация: 21/12/2012 - 20:03
ошибка при запуске optirun

Добрый вечер!

После установки драйвера nvidia при запуске optirun появляется следующая ошибка:

[ERROR]Cannot access secondary GPU - error: XORG Failed to load /usr/lib64/xorg/modules/libglamoregl.so: /usr/lib64/xorg/modules/libglamoregl.so: undefined symbol: _glapi_tls_Context

Как исправить?

Статус: 

Теги: 

Отредактировано: lecksys вкл 01/04/2014 - 22:13
DA
Аватар пользователя DA
Не в сети
Последнее посещение: 1 год 6 месяцев назад
Регистрация: 11/05/2012 - 18:24
Открытый баг
openSUSE 13.1 x64 | Linux 3.11 | KDE 4.13
openSUSE 12.3 x32 | Linux 3.7 | KDE 4.10
aliaksei1818
Аватар пользователя aliaksei1818
Не в сети
Последнее посещение: 2 года 8 месяцев назад
Регистрация: 15/07/2012 - 18:42
/etc/bumblebee/xorg.conf.nvidia

Попробуйте добавить секцию:

Section "Module"
Disable "glamoregl"
EndSection

Вообще странно, что использование optirun как-то связано с libglamoregl.so. Такое впечатление, что bumblebee параллельно смотрит в /etc/X11/xorg.conf.d. Сам же модуль libglamoregl.so прописан в файле 05-glamor.conf, и несмотря на ошибку, никак не влияет на запуск иксов, во всяком случае, если в системе используется карточка nvidia. Но видимо для bumblebee, это почему-то критично.
Хотелось бы еще увидеть:
/var/log/Xorg.0.log

jsullen
Аватар пользователя jsullen
Не в сети
Последнее посещение: 3 года 11 месяцев назад
Регистрация: 21/12/2012 - 20:03
Судя по ошибке после

Судя по ошибке после добавления секции "Module":

Cannot access secondary GPU - error: X did not start properly - отсутствие модуля glamoregl влияет на запуск X-ов.
Видимо, придётся вернуться пока на драйвер nouveau.