30 сообщений / 0 новое
Последнее сообщение
sofers
Аватар пользователя sofers
Не в сети
Последнее посещение: 3 года 11 месяцев назад
Регистрация: 17/10/2012 - 23:59
Torrent stream

Дорогие друзья, наверняка многим из Вас известна технология torrent stream. Кто не в курсе - прошу: http://torrentstream.org/ru/. Как эта вещь работает в Windows я уже опробовал и мне она очень во многом нужна в качестве просмотра футбольных каналов on-line или же видео материала из футбольных торрент-трекеров. Как видим на сайте есть версия только для Ubuntu в упаковке .deb. Известен способ конвертации deb в rpm с помощью конвертера alien. Но с его установкой на Open Suse 12.2 существуют маленькие проблемки: пакет perl из зависимостей конвертера подтягивается устаревшей версией и естественно не устанавливается. Итак круг замкнулся. Может кто чем сможет?

Теги: 

Отредактировано: lecksys вкл 01/04/2014 - 22:13
DA
Аватар пользователя DA
Не в сети
Последнее посещение: 2 года 3 месяца назад
Регистрация: 11/05/2012 - 18:24
пакет perl из зависимостей

пакет perl из зависимостей конвертера подтягивается устаревшей версией и естественно не устанавливается

Не понимать. В зузе слишком старый перл? Проверил, перл новее, чем в бунтах. Покажите, в чём ошибка, пожалуйста.
PS Если хотите, я могу поковырять вечером и попробовать закинуть в свою репку.

openSUSE 13.1 x64 | Linux 3.11 | KDE 4.13
openSUSE 12.3 x32 | Linux 3.7 | KDE 4.10
sofers
Аватар пользователя sofers
Не в сети
Последнее посещение: 3 года 11 месяцев назад
Регистрация: 17/10/2012 - 23:59
Уточнение 1

Дело в том, что в основных репозиториях OpenSuse 12.2 пакета Alien нет. Я добавил репозиторий из позапрошлого выпуска: 11.4. Я, конечно, понимаю, что этот пакет (по неведомым мне причинам) сообществом OpenSuse не поддерживается с недавних пор. Получается, что в системе установлен Perl 5.16, а Alien (из репозиторий 11.4) просит 5.12. Вот и все несостыковка. Оно и понятно. Дистрибутив новый и не все в нем из старых может работать.

r3d
Аватар пользователя r3d
Не в сети
Последнее посещение: 3 года 1 месяц назад
Регистрация: 04/09/2012 - 16:52
Дело в том, что в основных

Дело в том, что в основных репозиториях OpenSuse 12.2 пакета Alien нет.

Зато он есть в не_основных.

Я добавил репозиторий из позапрошлого выпуска: 11.4

Зачем, если есть пакеты для 12.2?

Дистрибутив новый и не все в нем из старых может работать.

"Установится" и "работать" не зависимы: у rpm есть ключик --nodeps [на свой страх и риск конечно же], но вам же лень разбираться Smile

Утилита alien - это крайнее средство, которое вовсе не гарантирует приемлемых результатов. А то может и поломать систему, man alien.

13.1 - Xfce
sofers
Аватар пользователя sofers
Не в сети
Последнее посещение: 3 года 11 месяцев назад
Регистрация: 17/10/2012 - 23:59
Не лень

Нет, не лень. "Установить" - установил, а "работать" - не работает. На счет того, что это средство крайнее - согласен. Далеко не всегда результат себя оправдывал и раньше. Я как - то установил Steam из deb, но брал информацию из англоязычных сайтов и не совсем понял суть процесса до конца. Но в целом суть была такова: разобрать упакованное в deb и собрать его в rpm уже средствами Suse. Тоже вышло кривовато. Однако нет torrent stream в пакете тарбола. Только deb. Что прикажете делать?

r3d
Аватар пользователя r3d
Не в сети
Последнее посещение: 3 года 1 месяц назад
Регистрация: 04/09/2012 - 16:52
Я видел, что в deb.

Я видел, что в deb. Единственный надежный вариант тут- сборка из исходников. А если разработчик не желает предоставлять исходники, то не пошел бы такой разраб в жопу, не? К тому же скоро подобный функционал может получить VLC, дело не стоит на месте))

13.1 - Xfce
DA
Аватар пользователя DA
Не в сети
Последнее посещение: 2 года 3 месяца назад
Регистрация: 11/05/2012 - 18:24
http://software.opensuse.org

http://software.opensuse.org/package/alien
http://software.opensuse.org/package/steam
Зачем ставить из старого релиза, когда есть нормальные пакеты?

openSUSE 13.1 x64 | Linux 3.11 | KDE 4.13
openSUSE 12.3 x32 | Linux 3.7 | KDE 4.10
sofers
Аватар пользователя sofers
Не в сети
Последнее посещение: 3 года 11 месяцев назад
Регистрация: 17/10/2012 - 23:59
Конечно пошел бы

Согласен. Нет исходников - нет публики. И, кстати, была мысль о том, что раз уж до ubuntu добрались, то доберутся и до других дистрибутивов. Касательно VLC не в курсе об их планах и разработках, но у такого комбайна не удивлюсь появлению такого функционала. В общем Вы предлагаете ждать. Ну что ж... подождем.

sofers
Аватар пользователя sofers
Не в сети
Последнее посещение: 3 года 11 месяцев назад
Регистрация: 17/10/2012 - 23:59
За ссылки

Большое спасибо за ссылки. Буду пробовать

r3d
Аватар пользователя r3d
Не в сети
Последнее посещение: 3 года 1 месяц назад
Регистрация: 04/09/2012 - 16:52
2ая ссыль - что это?

2ая ссыль - что это, хосспадебожемой? А вопрос пр старые пакеты я ТС уже задал. Или тут что, на каждый чих нужно линки давать? Crazy

13.1 - Xfce
r3d
Аватар пользователя r3d
Не в сети
Последнее посещение: 3 года 1 месяц назад
Регистрация: 04/09/2012 - 16:52
И, кстати, была мысль о том,

И, кстати, была мысль о том, что раз уж до ubuntu добрались, то доберутся и до других дистрибутивов.

Ну сколько можно? Либо это Open Source, либо просто_опция) Я вот юзаю офес от Softmaker, пока оно в rpm, но в случае косяков у разработчика в 2 клика заменю на другой. Просто они пока еще не лажали, вот и юзаю. примерно раз в месяц Smile

13.1 - Xfce
DA
Аватар пользователя DA
Не в сети
Последнее посещение: 2 года 3 месяца назад
Регистрация: 11/05/2012 - 18:24
Стим же.

Стим же.

openSUSE 13.1 x64 | Linux 3.11 | KDE 4.13
openSUSE 12.3 x32 | Linux 3.7 | KDE 4.10
DA
Аватар пользователя DA
Не в сети
Последнее посещение: 2 года 3 месяца назад
Регистрация: 11/05/2012 - 18:24
Перед установкой дебов и

Перед установкой дебов и прочими извращениями поищите сначала пакет на ОБС и пакмане Wink

openSUSE 13.1 x64 | Linux 3.11 | KDE 4.13
openSUSE 12.3 x32 | Linux 3.7 | KDE 4.10
Aviv
Аватар пользователя Aviv
Не в сети
Последнее посещение: 2 года 1 месяц назад
Регистрация: 15/02/2013 - 19:37
Не знаю, будет ли полной

Не знаю, будет ли полной заменой TorrentStreamu, но есть альтернатива - qBittorrent, можно просматривать те же вещи практически онлайн

slawdos
Аватар пользователя slawdos
Не в сети
Последнее посещение: 9 месяцев 6 дней назад
Регистрация: 13/05/2012 - 15:43
Просто некоторые сайты онлайн

Просто некоторые сайты онлайн-тв тупо навязывают данную прогу.
Есть какой-нить норм просмотрщик для linux?

oS Leap 42.1x64KDE
~ Morpheus, i know linux...

demon_od
Аватар пользователя demon_od
Не в сети
Последнее посещение: 5 лет 3 месяца назад
Регистрация: 13/03/2013 - 10:33
.

Всем привет...Кому-то удалось решить вопрос..?

DA
Аватар пользователя DA
Не в сети
Последнее посещение: 2 года 3 месяца назад
Регистрация: 11/05/2012 - 18:24
Ставите alien, конвертируете

Ставите alien, конвертируете скачанный deb, устанавливаете. Эпик вин!

openSUSE 13.1 x64 | Linux 3.11 | KDE 4.13
openSUSE 12.3 x32 | Linux 3.7 | KDE 4.10
demon_od
Аватар пользователя demon_od
Не в сети
Последнее посещение: 5 лет 3 месяца назад
Регистрация: 13/03/2013 - 10:33
.

Не получается сконвертить...(......@linux-f8k6:~> sudo alien -rc Downloads/acestream-local_2.0.0_amd64.deb Downloads/acestream-local_2.0.0_amd64.rpm generated
acestream-2.0.0-2.x86_64.rpm generated
File "Downloads/acestream-local_2.0.0_amd64.rpm" not found)
Сам файл появляется, но при установке :nothing provides liba52-0.7.4.so()(64bit) needed by acestream-2.0.0-2.x86_64......
Застрял тут....

DA
Аватар пользователя DA
Не в сети
Последнее посещение: 2 года 3 месяца назад
Регистрация: 11/05/2012 - 18:24
Ох уж этот alien. Попробую

Ох уж этот alien. Попробую пересобрать вечером.

openSUSE 13.1 x64 | Linux 3.11 | KDE 4.13
openSUSE 12.3 x32 | Linux 3.7 | KDE 4.10
demon_od
Аватар пользователя demon_od
Не в сети
Последнее посещение: 5 лет 3 месяца назад
Регистрация: 13/03/2013 - 10:33
.

Попробую днем еще поковырять...)) Финал востока в NBA уже закончился-так и не посмотрел viasat ночью)))

DA
Аватар пользователя DA
Не в сети
Последнее посещение: 2 года 3 месяца назад
Регистрация: 11/05/2012 - 18:24
Готовь сани летом!..

Готовь сани летом!..

openSUSE 13.1 x64 | Linux 3.11 | KDE 4.13
openSUSE 12.3 x32 | Linux 3.7 | KDE 4.10
demon_od
Аватар пользователя demon_od
Не в сети
Последнее посещение: 5 лет 3 месяца назад
Регистрация: 13/03/2013 - 10:33
.

Не получается победить....((

DA
Аватар пользователя DA
Не в сети
Последнее посещение: 2 года 3 месяца назад
Регистрация: 11/05/2012 - 18:24
Чёрт, совсем про вас забыл

Чёрт, совсем про вас забыл Sad Попробуйте просто распаковать deb как архив в домашний каталог и запустить файл из usr/bin. Пускайте из терминала и смотрите на что ругается. Если будет непонятно, постите сюда.

openSUSE 13.1 x64 | Linux 3.11 | KDE 4.13
openSUSE 12.3 x32 | Linux 3.7 | KDE 4.10
DA
Аватар пользователя DA
Не в сети
Последнее посещение: 2 года 3 месяца назад
Регистрация: 11/05/2012 - 18:24
Уcтановите пакет liba52-0,

Уcтановите пакет liba52-0, после чего создайте ссылку:


sudo ln -s /usr/lib64/liba52.so.0 /usr/lib64/liba52-0.7.4.so

(для не х64 замените lib64 на lib). И устанавливайте с нарушением зависимости. У меня запустилось, но я так и не понял, как тестировать.

openSUSE 13.1 x64 | Linux 3.11 | KDE 4.13
openSUSE 12.3 x32 | Linux 3.7 | KDE 4.10
demon_od
Аватар пользователя demon_od
Не в сети
Последнее посещение: 5 лет 3 месяца назад
Регистрация: 13/03/2013 - 10:33
.

Спасибо, ща поиграюсь)))

DA
Аватар пользователя DA
Не в сети
Последнее посещение: 2 года 3 месяца назад
Регистрация: 11/05/2012 - 18:24
Пересобрал deb в rpm, репка

Пересобрал deb в rpm, репка для 12.3: http://pmbs.links2linux.org/download/home:/dap/openSUSE_12.3/home:dap.repo
При установке будет такая же ошибка, но внутри уже есть нужная ссылка и зависимость. Рядом собрано и для 12.2.

openSUSE 13.1 x64 | Linux 3.11 | KDE 4.13
openSUSE 12.3 x32 | Linux 3.7 | KDE 4.10
demon_od
Аватар пользователя demon_od
Не в сети
Последнее посещение: 5 лет 3 месяца назад
Регистрация: 13/03/2013 - 10:33
.

Спасибо, сам плеер теперь в браузере запускается, но видео не тянется....(...больше ничего не нужно инсталить дополнительно?)

DA
Аватар пользователя DA
Не в сети
Последнее посещение: 2 года 3 месяца назад
Регистрация: 11/05/2012 - 18:24
Это не ко мне вопрос

Не знаю Wink Порыскайте по их форуму, если будет нужно что исправить, сделаю.

openSUSE 13.1 x64 | Linux 3.11 | KDE 4.13
openSUSE 12.3 x32 | Linux 3.7 | KDE 4.10
demon_od
Аватар пользователя demon_od
Не в сети
Последнее посещение: 5 лет 3 месяца назад
Регистрация: 13/03/2013 - 10:33
.

так в этом то и прикол...там тема тож глухая...сегодня поднял-мож кто откликнеться...))
http://forum.torrentstream.org/index.php?topic=1678.0

canavarro
Аватар пользователя canavarro
Не в сети
Последнее посещение: 3 года 4 месяца назад
Регистрация: 17/01/2015 - 21:11
Ребята кто нибудь пробовал

Ребята кто нибудь пробовал acestream и 13.2? Заслали в кукуево, где нет тарелки, а футбол смотреть надо, все таки финалы идут лиги чемпионов и европы. Вот и пытаюсь подготовить сани летом. А то не дай бог мысли начнут посещать виндоз поставить!