33 сообщения / 0 новое
Последнее сообщение
Nika-7
Аватар пользователя Nika-7
Не в сети
Регистрация: 13/10/2012 - 15:07
VLC - старые глюки в новоы версии

Доброго времени суток.

Во первых хочу сказать, что я вернулась.
Сюда и на СуСи. Соскучилась по вам., и ОС красивая.

У меня возникла проблема с VLC - поставила быстрым способом через Yast и теперь VLC
запускается и не воспроизводит видео.
просто пишет, что он не поддеоживает формат.

Хотя в 11,2 все работало.
Я знаю, что ответ на поверхности, но я его пока не вижу..
Подскажите мне пожалуста!

Теги: 

Отредактировано: lecksys вкл 01/04/2014 - 22:11
Администратор
lecksys
Аватар пользователя lecksys
В сети
Регистрация: 02/04/2012 - 11:54

в других плеерах пробывали?


Профессиональный тролль. Работаю за еду.

Nika-7
Аватар пользователя Nika-7
Не в сети
Регистрация: 13/10/2012 - 15:07

кофеин тоже не работает.
Но у меня стоит репозитарий VLC и он устанавливался с библиотеками.

Я вернулась!

alv
Аватар пользователя alv
Не в сети
Регистрация: 09/05/2012 - 01:28

Скорее всего не установился кодек для данного формата, как-то у меня такое было. А кстати, какой именно формат не хочет поддержать?
Можно поискать нужный кодек в репозиториях.
Но я обычно ставлю Mplayer - практически всегда он вытягивает всё необходимое как зависимости.

Алексей Федорчук aka alv

CyberDaemon
Аватар пользователя CyberDaemon
Не в сети
Регистрация: 07/06/2012 - 15:54

w32codec-all пробовали ?

alv
Аватар пользователя alv
Не в сети
Регистрация: 09/05/2012 - 01:28

а VLC его разве не тянет за собой? Mplayer тянет

Алексей Федорчук aka alv

Nika-7
Аватар пользователя Nika-7
Не в сети
Регистрация: 13/10/2012 - 15:07

w32codec-all нет в подключенных репозитариях.
Запускаю Mp4 - "Не найден подходящий модуль декодирования:
VLC не поддерживает аудио или видео формат "h264". К сожалению, вы не можете это исправить."

Раньше все это проигрывалось VLC
Устанавливалось"В один клик" может действиельно нет этих кодеков.

А какие нужно поставить и откуда?

Я вернулась!

alv
Аватар пользователя alv
Не в сети
Регистрация: 09/05/2012 - 01:28

По идее всё это хозяйство должно быть в нём. Или поищите по "домашним" каталогам.
У меня навскидку в OBS нашлось такое:

h264enc is an advanced and powerful interactive menu-driven shell script written for the GNU/Linux

Логично предположить, что раз существует кодер, должен быть и декодер smiley

Алексей Федорчук aka alv

Nika-7
Аватар пользователя Nika-7
Не в сети
Регистрация: 13/10/2012 - 15:07

У меня есть
libx264-128 - A free h264/avc encoder - encoder binary
x264 - X264 - a free h264/avc encoder
vlc - VLC - Video Lan Client
vlc-qt - VLC: VideoLAN Client - Qt interface
vlc-noX - VLC: VideoLAN Client - without X dependencies
vlc-gnome - VLC: VideoLAN Client - Gnome Access Modules
vlc-aout-pulse - VLC Audio Out for Pulse Audio
libvlccore5 - Shared library libvlc
libvlc5 - Shared library libvlc

MP4 проигрывается без изображения

Я вернулась!

piker
Аватар пользователя piker
Не в сети
Регистрация: 12/08/2012 - 20:46

Попробуйте через YaST его (VLC) переустановить...

taib
Аватар пользователя taib
Не в сети
Регистрация: 22/05/2012 - 21:59

Пришлось поставить mplayer для просмотра, дело в том что до какого то момента работал VLC а потом перестал с ошибкой "VLC не поддерживает аудио или видео формат "mp4v". Тот же фильм выводится через mplayer без ошибок.

openSUSE 12.2 Linux desktop 3.4.6-2.10-desktop

Nika-7
Аватар пользователя Nika-7
Не в сети
Регистрация: 13/10/2012 - 15:07

mplayer работает, но мне очень непривычно и неудобно.

Очень хочу вернуть VLC

Я вернулась!

alv
Аватар пользователя alv
Не в сети
Регистрация: 09/05/2012 - 01:28

Вообще-то у mplayer'а есть много графических морд - от простейшего gmplayer'а до всяких навороченных, типа как нынче с ROSA продвигается. Думаю, что среди них можно найти и подобие VLC. Разве что интерфейс последнего оскорбляет эстетическое чувство пользователей mplayer'а smiley
Ну а результат Вы видите сами - mplayer работает, VLC - не всегда.

Алексей Федорчук aka alv

Vlad60
Аватар пользователя Vlad60
Не в сети
Регистрация: 22/05/2012 - 08:34

попробуйте установить VLC media player for openSUSE,но при этом лучше сделать это через YAST ,чтобы установились все библиотеки

640 КБ должно быть достаточно для каждого. (Билл Гейтс, 1981 г)

Nika-7
Аватар пользователя Nika-7
Не в сети
Регистрация: 13/10/2012 - 15:07

Попробовала
------------------------
Получение метаданных репозитория 'Servername: download.videolan.org /' .........................................................[готово]
Получение метаданных репозитория 'VLC' .........................................................................................[готово]
Сбор кэша репозитория 'VLC' ....................................................................................................[готово]
Загрузка данных о репозиториях...
Чтение установленных пакетов...
'vlc' уже установлен.
Нет кандидатов на обновление 'vlc-2.0.3-1.28.i586'. Новейшая версия уже установлена.
Разрешение зависимостей пакетов...

Нечего выполнять.

-------------------------------
Не помогло

Я вернулась!

Vlad60
Аватар пользователя Vlad60
Не в сети
Регистрация: 22/05/2012 - 08:34

Проверьте,чтобы libavcodec54,liavdevice54,liabvfilter3,libavformat54,libavutil51,libvlc5,libvlccore5,libx264-125,libvlccore4,x264,ну и на всякий случай ffmpeg ,были установлены из этого-же репозитория

640 КБ должно быть достаточно для каждого. (Билл Гейтс, 1981 г)

barnsky
Аватар пользователя barnsky
Не в сети
Регистрация: 29/05/2012 - 20:29

Попробуйте перейти на Packman. Предварительно удалите vlc ( zypper rm vlc ), отключите репы vlc ( zypper mr -dR VLC ), поставьте vlc из Packman ( http://ru.opensuse.org/%D0%94%D0%BE%D0%BF%D0%BE%D0%BB%D0%BD%D0%B8%D1%82%... ). Возможно это поможет.

Nika-7
Аватар пользователя Nika-7
Не в сети
Регистрация: 13/10/2012 - 15:07

Из них я и ставила первый раз

Я вернулась!

slawdos
Аватар пользователя slawdos
Не в сети
Регистрация: 13/05/2012 - 15:43

мне кажется кодеки он и не подхватит по умолчанию. Если в кофеине показывает данный файл а в vlc нет - скорее всего дело в плагинах vlc. Сильно его не пользовал, но чтото про это слышал. Если не показывает нитам-нитам, попробуйте поставить кодеки как написано тут (можно ванклик, можно через терминал) http://www.opensuse-guide.org/codecs.php

os13.1x64KDE

Nika-7
Аватар пользователя Nika-7
Не в сети
Регистрация: 13/10/2012 - 15:07

В VLC есть только звук, в кофеине вообще ничего.
Поставила все обновления, съелось 1,5 Гб диска
Толка нет

Прямо виндос какой то получился
Я имею ввиду всю эту кучу ненужных пакетов

Теперь вопрос в другом - как их удалить?
Так не хочется переустанавливать Суси заново

Я вернулась!

slawdos
Аватар пользователя slawdos
Не в сети
Регистрация: 13/05/2012 - 15:43

Сомневаюсь что Вы знаете какие пакеты можно удалять. Лично я устанавливаю только _нужные_ исправления. А так все удаляется через yast.

На Вашем месте я бы переустановил все таки. Чему-то да новому научитесь.

зыЖ Лично я переустанавливаю регулярно, так как экспериментирую с системой.
зыыЖ Кстати кодеки поставили по моей ссылке?

os13.1x64KDE

aliaksei1818
Аватар пользователя aliaksei1818
Не в сети
Регистрация: 15/07/2012 - 18:42

Неплохо бы взглянуть:
vlc -v /путь/до/mp.4
На основе своего выхлопа:


aliaksei@dhcppc0:> vlc -v Prodigy\ Omen.mp4
VLC media player 2.0.2 Twoflower (revision 2.0.1-453-g40d9fef)
[0x8faf200] dbus interface: listening on dbus as: org.mpris.MediaPlayer2.vlc
[0x8fb0cf0] main interface error: no suitable interface module
[0x8f8e3f0] main libvlc error: interface "globalhotkeys,none" initialization failed
[0x8f8e3f0] main libvlc: Запуск vlc с интерфейсом по умолчанию. Используйте 'cvlc' для запуска vlc без интерфейса.
[0xb24fd700] faad decoder warning: decoded zero sample
[0xb2405d50] avcodec decoder warning: disabling direct rendering
...

Могу предположить:

zypper in libavcodec{52,54} *faad2
Vlad60
Аватар пользователя Vlad60
Не в сети
Регистрация: 22/05/2012 - 08:34

="aliaksei1818"
zypper in libavcodec{52,54} *faad2

еще добавил бы


zypper in -r VLC -f libavutil51 libx264-125 x264



и вывод (только то что выделено будет цветом)
vlc -vvv --color --no-plugins-cache --list
P.S.Сейчас проверил,если удалить libavutil51 то VLC не воспроизводит mp4,вернее есть только звук и ошибка

No suitable decoder module:
VLC does not support the audio or video format "h264". Unfortunately there is no way for you to fix this.

640 КБ должно быть достаточно для каждого. (Билл Гейтс, 1981 г)

aliaksei1818
Аватар пользователя aliaksei1818
Не в сети
Регистрация: 15/07/2012 - 18:42

К чему мне возражать, тем более, что Вы абсолютно правы:
http://ru.wikipedia.org/wiki/FFmpeg#.D0.9A.D0.BE.D0.BC.D0.BF.D0.BE.D0.BD...

модератор
DA
Аватар пользователя DA
Не в сети
Регистрация: 11/05/2012 - 18:24

Ну у меня в vlc без шаманства звука нет, дык и что? Юзаю smplayer и не парюсь. Vlc - комбайн, причём плохой комбайн: много чего умеет, но везде какие-то мелкие косяки постоянно.

openSUSE 13.1 x64 | Linux 3.11 | KDE 4.11
openSUSE 12.3 x32 | Linux 3.7 | KDE 4.10
barnsky
Аватар пользователя barnsky
Не в сети
Регистрация: 29/05/2012 - 20:29

Что-то похожее у меня было, собрал дрова криво на видюху.
Кстати, у меня плеер показывает, а ошибки похожие :
( arnsky@amd">barnsky@amd:~> vlc -v /home/barnsky/HIT2/Video/Скайлайн.mp4
VLC media player 2.0.2 Twoflower (revision 2.0.1-453-g40d9fef)
[0x118cc28] main interface error: no suitable interface module
[0x1176178] main libvlc error: interface "globalhotkeys,none" initialization failed
[0x1176178] main libvlc: Запуск vlc с интерфейсом по умолчанию. Используйте 'cvlc' для запуска vlc без интерфейса.
[0x7fe8f0002368] mp4 demux warning: elst box found
[0x7fe8f0002368] mp4 demux warning: CTTS table
[0x7fe8f2ad3d58] faad decoder warning: decoded zero sample
[0x7fe8f0c07518] avcodec decoder warning: disabling direct rendering
[0x7fe8cc0069e8] main audio output warning: PTS is out of range (-33184), dropping buffer
)
не в кодеках дело, мне кажется.

Nika-7
Аватар пользователя Nika-7
Не в сети
Регистрация: 13/10/2012 - 15:07

Я удалила VLC и несколько попавших под горячую руку игрушек, которые стояли по умолчанию.
И поставила 2й системой убунту. Она такая быстрая.

А для суси видимо действительно лучше использовать gmplayer.

Я вернулась!

Администратор
lecksys
Аватар пользователя lecksys
В сети
Регистрация: 02/04/2012 - 11:54

т.е. теперь вы уже не вернулись? smiley


Профессиональный тролль. Работаю за еду.

Nika-7
Аватар пользователя Nika-7
Не в сети
Регистрация: 13/10/2012 - 15:07

Я вернулась.
Суси хорошая, только выглядит менее доработанной для использования по сравнению с Убунтой.
Я поставила Суси ради оформления, а Убунту для быстроты и удобства.

Я вернулась!

slawdos
Аватар пользователя slawdos
Не в сети
Регистрация: 13/05/2012 - 15:43

Вообщем я поставил в one-click от сюда http://www.videolan.org/vlc/download-suse.html, все заработало.

os13.1x64KDE

taib
Аватар пользователя taib
Не в сети
Регистрация: 22/05/2012 - 21:59

Вот у меня раньше работало, но в какой то момент перестал выводить видео. И что же могли такое зацепить в обновлениях.

openSUSE 12.2 Linux desktop 3.4.6-2.10-desktop

Balabas
Аватар пользователя Balabas
Не в сети
Регистрация: 01/06/2013 - 14:46

У меня opensuse 12.2 и VLC с недавнего времени перестал работать. Сразу погрешил на обновления. Но долго руки не доходили. Полез в инэт искать. Нашел среди прочего эту ветку. И только после этого пошел в YaST. А нужно было всего-то установить vlc-codecs. По всей видимости, при обновлении в репозитории Packman (у меня оттуда стоит), возникли новые зависимости, но по умолчанию они не установлены в качестве требуемых, а описываются как:


vlc-codecs - VLC: VideoLAN Client - Codec extension

This Package enhances the functionality of the VLC VideoLAN Client with Codecs that are not available in a stock openSUSE distribution.


После установки всё работает!

Pavlo
Аватар пользователя Pavlo
Не в сети
Регистрация: 22/09/2012 - 19:40

Была с этим плеером(VLC) такая же проблема.Решил его установкой заново,только не помню из какого источника.